ロリポップ のスタンダードプランで、a-blog cmsの「アクセス制限」をつかってbasic認証をしようとしたが、うまくいかない


問題

  • ロリポップ のスタンダードプランで、a-blog cmsの「アクセス制限」をつかってbasic認証をしようとしたが、うまくいかない

解決方法

  • ロリポップにa-blog cmsをインストールする場合、phpは7.3(モジュール版)を選択する
  • CGI版でも動作するが、basic認証が正しく動作しない(basic認証のダイアログは表示されるが、正しい情報をいれても再度ログインを求められる)
  • CGI版を選択した後でも、モジュール版を選択し直す(変更する)ことで、上記は解決する

追記

  • 2020/03/30現在、ロリポップスタンダードプランにて、ionCube Loaderの動作を確認している。
  • phpのバージョン7.3でも問題なく稼働
  • 簡単インストールよりも、通常のインストール手順のほうが、手順は増えるがスムーズにインストールできる印象(2.10系の簡単インストーラーをいれたところ、php5.6にしてくれとでて、7系でインストールできなかった)

関連記事

この記事のハッシュタグ から関連する記事を表示しています。

a-blog cmsのメディアダウンロードの仕様は「media_download_link: v1」を設定してもハッシュ値なしのURLに戻るわけではない

a-blog cmsを1.7から最新版(2020年6月25日時点:最新 Ver.2.11.14)にアップデートする手順

Transmitでダウンロードした日本語名ファイルが文字化けしてしている→表示からエンコーディングを調整して再度ダウンロード

a-blog cmsのユーザインポート、エラーの「code=」は、ユーザの「user_code」のことではない

a-blog cmsのシークレットブログでは、ユーザ一覧は、テンプレートに出力することができない

a-blog cmsのファイルアップロードでエラーが出るときは、最初にphpの設定をチェック